Train Sim Safe House
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Route-Riter issues

Page 2 of 2 Previous  1, 2

Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Sat 18 Jul 2020, 10:08 pm

Hi Jonathan,
As well as fixing the bug which could have caused your spurious 'missing stock' reports, various cosmetic changes have been made, together with improvements to the handling of Comments and keywords.

There is no change to the fundamental operation of the program so the readme remains the same.

Please let me know if you'd like to check it out before I upload it. I appreciate that you won't be able to fully test all of its functions, but any feedback could be useful!

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Sun 19 Jul 2020, 9:39 am

Happy to look at it.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Sun 19 Jul 2020, 6:55 pm

Hi Jonathan,
Thanks, mate Smile

Attached is a new .exe file and a short readme, indicating the main difference with previous versions.

I welcome all comments, good or bad and suggestions for further enhancements.

Cheers,
Ged

EDIT : Attachment removed and replaced in post dated 24 July


Last edited by slipperman12 on Fri 24 Jul 2020, 10:48 am; edited 1 time in total


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Wed 22 Jul 2020, 6:00 pm

I have had a good play and it seems to work perfectly except when used on my massive set of US routes and stock, when it still flags everything as missing.
It did throw up some amusing real errors, such as one (Australian) consist which has (comment) as the stock name in one place, and a few places where the name of the stock is not quite correct in an activity and its consists.
But no problems at all with the utility.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Wed 22 Jul 2020, 7:06 pm

Hi Jonathan,
Thanks Smile
I'm sorry you're still having problems with your 'Mega-installation' Sad   I really would like to find out why!

As you're not reported any system error messages, can I assume there aren't any?  
Is the stock reported as missing even when you only select one activity?

Have you tried the other functions?   If not, will you please run the following :

(a)  Check All Consists
(b)  Unused Consists
(c)  Stock used by all Acts in Installation
(d)  Stock not used by any Acts
(e)  Press [Alt+L] to show 'Accum Lists'

DO NOT use the 'Save and Delete' function of  (b) and (d) and after obtaining the display for all of them,, press the "Back" button to return to the main screen.
Also, I do not require you to send me any of the reports.  I'm only trying to find out if the program 'falls-over' when asked to perform those functions.  If it does, please let me know which one/s and, if possible, send me a screenshot of any system errors reported.

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Thu 23 Jul 2020, 2:29 pm

I have now used the experimental version on two folders. First Modern British Routes (11 routes, 435 consists in use, many more not in use, 1734 trainsets. No problems with any of the reports, including the Alt+L report. It did flag up some stock which was genuinely missing but it was all in unused consists - probably a hangover from the installation on a previous computer. It did flag up missing stock correctly.
Then Narrow Gauge Routes, 32 routes, 155 consists (originally many more, as above), 665 trainsets. Everything again fine except for one unexplained error flagged, an apparent wrong TrainCfg in a Consist. I have attached it as I cannot see the issue.
I have not tried it again on the American routes folder, but intend to play to see if reducing the number of routes in use makes any difference, and similarly if possible the number of Consists and Trainsets, though that will take a while. So don't wait by the computer for a report!. And first I want to try it on some successively larger collections of routes, stock and consists.
But my reaction is that it now works fine with any sensibly sized installation.
One minor comment: it uses a different convention for sorting into alphabetical order from that used by Windows which makes it a bit of a chore at times to find things it has flagged up. If it would be easy it would be good to have it to work to the same convention. But that is not a big issue.
Jonathan
Attachments
Route-Riter issues - Page 2 Attachment
Billard A80D.zip You don't have permission to download attachments.(1 Kb) Downloaded 1 times

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Thu 23 Jul 2020, 3:09 pm

Hi Jonathan,
Thank you Smile
At least you've given me an easy one to solve!! The TrainCfg entry has a space in it so should be in quotes - "Billard A80D".

I don't understand your comment about the 'sorting convention'. Which reports are you referring to? Reports 1 and 2 are presented in the order the data is read from the selected route's Activities folder.

Cheers,
Ged




Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Thu 23 Jul 2020, 6:59 pm

Doh! I really should have realised that about the TrainCfg.
The order is not a major issue. I have noticed that there are various conventions.
It was Report 4 I had been using. Here is an excerpt:
#BR_Class118_2carrev_BRGs_WR
#BR_Class118_2carrev_BRGw_WR
#BR_Class118_2car_BRGs_WR
#BR_Class118_2car_BRGw_WR
#BR_Class118_3carrev_BRGs_WR
#BR_Class118_3carrev_BRGw_WR
#BR_Class118_3car_BRGs_WR
#BR_Class118_3car_BRGw_WR

In the folder on the PC they appear in this order:
#BR_Class118_2car_BRGs_WR
#BR_Class118_2car_BRGw_WR
#BR_Class118_2carrev_BRGs_WR
#BR_Class118_2carrev_BRGw_WR
#BR_Class118_3car_BRGs_WR
#BR_Class118_3car_BRGw_WR
#BR_Class118_3carrev_BRGs_WR
#BR_Class118_3carrev_BRGw_WR
In other words it it treating the _ symbol differently from Windows. (These are some of rufiskins’ many Consists for BR DMUs).
I hope that helps explain.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Thu 23 Jul 2020, 10:04 pm

Hi Jonathan,
Many thanks for the explanation Smile

I've been able to reproduce the Class 118 consists list situation, but don't know if I can do anything about the order as they are displayed in the order the program reads them from the folder!

I will, however, see if anything can be done.

Cheers,
Ged




Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Fri 24 Jul 2020, 8:13 am

I don't think it is worth a lot of energy or time.
Many thajks for all the useful programs you have produced.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Fri 24 Jul 2020, 10:46 am

Hi Jonathan,
It didn't take a lot of time!  Just a couple of minutes!!
As I mentioned, I didn't sort the list before displaying it so, on a whim, I sorted it (one additional line of code) and, lo! and behold! it came out in the same order as the Explorer list.  I don't know how or why, but I'm not asking any questions!!

Attached is the new .exe file (in a .zip) for your appraisal Smile  I've not changed the version number; it will become v3.2 when it's released.

I know we're still trying to sort out why you got so many erroneous missing stock reports in your very large installation.

Cheers,
Ged

EDIT 10 August 2020 : The attachment has been removed as MSTS_ActMan v3.2 is now available from the TSSH library.


Last edited by slipperman12 on Mon 10 Aug 2020, 7:28 pm; edited 1 time in total


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Fri 24 Jul 2020, 5:00 pm

As a first stage I have now created a folder (not American) with 28 routes, 2142 Consists and 2443 Trainsets. Activity Manager seems to work perfectly. It did flag up missing stock etc but anything flagged as missing really was missing. One small query. When I tried Alt+L in the right hand list there was one entry ion red (54) Invalid. Not sure quite what it meant.
The next stage is to make it about 50% bigger and check again. Something probably for tomorrow.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Fri 24 Jul 2020, 7:33 pm

Hi Jonathan,
Apologies for the 'Invalid' consist name - I may have missed reporting one or more errors.

May I suggest that you bring the same list up again and click on that 'Invalid' entry.. There will be 54 occurrences of it, but they won't all necessarily be the same consist, just 54 which are invalid for some reason.  You should be able to track each one down from the information given.

It is possible that they've already been reported in the Selected Activity, All Activities in Route and/or Check All Consists reports.

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Sat 25 Jul 2020, 8:55 am

I have looked at the Report (attached). All the errors relate to one route, and there are quite a few repeats. What is not clear to me is what is wrong in each case. I took one example (Amlwch Angler) and looked at all the files but they are all present and seem to be OK.
I have also now increased the folder to 36 Routes, 2818 Consists and 2121 Trainsets. Activity Manager still works perfectly. I'll try making it bigger again today, though it is beginning to need some faking to get enough material.
I am beginning to wonder if iut is not size but some undetected fault in my American routes setup.
Jonathan
Attachments
Route-Riter issues - Page 2 Attachment
report5.zip You don't have permission to download attachments.(1 Kb) Downloaded 1 times

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Sat 25 Jul 2020, 11:57 am

Hi Jonathan,
This is an odd one!!  I've just run my NWC route through the latest ActMan and received no errors and no  consists called "Invalid - 1" in the [Alt+L] list!

The "Invalid -1" name would indicate either an invalid character in the value of TrainCfg or that the open bracket following 'TrainCfg' is missing.

Could you please send me your 1K11(t) consist so that I can compare it with mine and, probably substitute mine.

Can you please, also tell me if, when you run "Check All Activities" for the NWC route, you get these consists reported as being in error?  The [Alt+L] list WILL give these results if errors have not been corrected.

One final question, for now - I'm sure it's not relevant, but it has to be asked!  Are you using the NWC route from UKTS or the original from The Class 15 Preservation Society?

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Sat 25 Jul 2020, 4:43 pm

Update
There was a simple reason for much of the Invalid list. I had accidentally parked the Consist 1K11(t) out of the way so it was missing in the installation. Once I put it back the Invalid message disappeared. Doh!
And I have now increased the trial installation to 43 Routes, 2604 Consists (all in use) and 3957 Trainsets.
Activity Manager works perfectly.
So the next stage is to make a copy of the American routes folder and gradually remove content to see what happens. But it will probably be some time before I find anything useful.
There is still a slight inconsistency in ordering between the program and Windows.
It seems only to affect numbers.
For example, take the list from your report
0280orig
03059
08243
093x
121_Arriva
1409
142006atwv
142074vall
143
Windows will list them in the order
093x
121 Arriva
143
0280orig
1409
03059
08243
142006atwv
142074vall
Your program goes by the first digit, then the second and so on taking no account of the number of digits, whereas Windows seems to take more account of the number of digits.
But to be honest it is such a small issue I would not put any effort into it. I think it probably now the time to issue this version of ActMan.
Jonathan



Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Sat 25 Jul 2020, 10:48 pm

Hi Jonathan,
Thanks Smile
For information, my program, like most others written in C#, uses Alphabetic Sort whereas Windows Explorer uses Natural Numeric Sort . There is no method built into C# which uses the Natural Numeric Sort, but an external procedure has been written by a third party, but I don't think it's worth the effort to attempt to include it in ActMan.

I HAVE been able to reproduce the 1K11(t) consist reported as "Invalid - 1", but only if the Train_Config entry of the Service file contains an invalid character AND if the resulting errors reported on Reports 1 or 2 haven't been corrected.
If this is anything like the actions you carried out before selecting [Alt+L], then I'll be pleased Smile If not, and you can remember your actions, in detail, it may help. Just removing the consist/s out of the folder wouldn't cause this situation.

Omitted from the readme is the stipulation that all errors shown in Reports 1 and 2 MUST be corrected before using [Alt+L] with a recommendation that the route's data also be reloaded. This will be added to the v3.2 document..

Cheers,
Ged








Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Mon 27 Jul 2020, 11:17 am

Hi Jonathan,
Today, I've had occasion to install the original LSE route (v1.2) as part of  testing a new ex-MT pack.  Going into AE to check an activity, an error with a consist was reported.  This is not relevant to the ActMan problem you originally reported, but I used ActMan v3.1 to check all the activities.  At this point, I got several "missing stock" reports, even though they were present.  Selecting one of the activities to check individually resulted in a 'system' error.  This pointed to the bug I'd found following your initial report.  I'm extremely  surprised that nobody else reported the same problem as it was introduced in v3.1 which was uploaded Feb 2019.  It wasn't caused by any combination of data, but purely by a coding error, for which I apologise  Embarassed  

Due to the foregoing and provided you don't come up with anything more for me to investigate (   Wink  ),  I'll be uploading v3.2 this week.

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Mon 27 Jul 2020, 5:39 pm

Sorry to be so long replying but I have been off-line doing a back-up.
Re your question, there certainly were uncorrected errors in some of the consists, in terms of missing stock, as I have been struggling to find some of the items used in activities, including one in a recent activity for Cornish Main Lines. So that may have triggered the message I asked about. I'll therefore look at the service file for the activity which uses 1K11(t).
Not to worry about the alphabetical order, though it is an interesting quirk. It was just something which popped up when I was looking for unused Consists to move them to a holding folder. There seem to be an enormous number of such Consists with recent stock downloads, usually of course because they have been multiple units. The tweak you did made things much easier.
I think you should assume that the current version is as good as it is going to get.
What we really need now is an Open Rails Activity generation program to replace the one which comes with MSTS. I have heard that one is being worked on but have not seen any news for a couple of years. (No, I am not suggesting it as your next project!)
Anyway, nay thanks for being so patient with me.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Mon 27 Jul 2020, 6:28 pm

Hi Jonathan,
No problem, mate Smile

Although I've been able to reproduce the 'Invalid - 1' entry for consist 1K11(t), you haven't (yet) convinced me that it was the same as caused the error on your system.  When I ran the NWC route through MSTS_ActMan just after I'd installed it and without making any modifications to any files, no errors were reported.  Therefore, I can only think that you made some edits in the CONSISTS/TRAINSETS folders, probably while MSTS_ActMan was sitting on your Desktop, after it had read the database , then you returned to it and ran the [Alt+L] routine.  The only way to ensure that the program has all the current data is to press the "START" button and re-select the route.  Because consists and stock can be used by more than one route, pressing "START" causes all activities in all routes in the installation to be processed.

I will leave it a couple of days to see if you come up with anything!

Yes, I believe there is an Activity Creator in, or part of, TSRE  but development seems to have stalled.  I've not even had a look at it - maybe I should!!  I'm sorry, but the ability to create such a program is well outside of my pay-grade!!

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Mon 03 Aug 2020, 8:46 pm

Hi Jonathan,
I hope you're all right, mate.
I appreciate that 'real life' always has to take precedence over this hobby of ours, but I sent you a PM last week and it's not been picked it up yet!

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Sun 23 Aug 2020, 6:42 pm

Final report on Activity Manager
I have created a separate folder of routes and stock to test based on the American material I have.
The “Check all consists” fails only if the Activity “RNE--TROOP TRAIN 1967 EB SS” for the freeware ATSF Seligman Sub is present. If it is, then it shows all stock as missing.
One other activity caused a problem: “05 CNJ Race Train SB 1974” for the Blue Comet route. This caused the program to stop if it was present.

As a final test I created an even more massive installation by including copies of the same rolling stock and Activities with suffices to the file names. This produced an installation with 132 Routes, 6844 Consists and 16676 Rolling stock folders. I am pleased to say that Activity Manager worked perfectly.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Sun 23 Aug 2020, 9:21 pm

Hi Jonathan,
If you've still found problems, then, surely, that can't be the 'final report' can it?

I'm assuming these activities are available as freeware - I'll see if I can find them!

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Sun 23 Aug 2020, 9:36 pm

I need to look at the two files, but my assumption is that there is something awry in the files which is causing the problem, not something about Activity Manager, as when I isolated them Activity Manager worked perfectly.
In case you want to have a look they are attached.
And it is certainly not the size of the installation.
Jonathan
Attachments
Route-Riter issues - Page 2 Attachment
05 CNJ Race Train SB 1974.zip You don't have permission to download attachments.(21 Kb) Downloaded 2 times

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Sun 23 Aug 2020, 10:30 pm

Hi Jonathan,
Thanks.
I downloaded the two activity packs and added the consists to my installation. Running MSTS_ActMan didn't result in a lock-up.

I also visually checked the two .act files you attached One of them, 05 CNJ Race Train SB 1974, has, on line 1849, an entry with no space between the file and folder names. I'm not able to use that file, so I created the same situation in a default activity file. MSTS_ActMan successfully reported the error and didn't 'freeze'.

This would seem to indicate that, whatever is causing your problem, isn't the same as before (thank goodness!!). I'm probably not in a position to obtain all the stock required to run these activities, so any more information you can give will be helpful, even just a screenshot of the program in its 'frozen' state could be useful.

Cheers,
Ged




Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Mon 24 Aug 2020, 3:23 pm

Hi Jonathan,
The original activities do not display any errors in MSTS_ActMan, so they can only have been introduced by manually editing the files. I accept this is no excuse for my program not reporting them correctly, but it does mean that I don't need to rush out a correction!

RNE -- Troop Train 1967 EB SS
Line 918 -- WagonData ( UP_Box-492257 "UP Box Pack ) -- missing closing quotes in folder name
Line 3996 -- WagonData ( atsf36703 "ATSF Pack"4 ) -- this did not cause the program to fail, just FYI

05 CNJ Race Train SB 1974
Lines 804 - 807 -- An Engine entry with nothing between the EngineData brackets. An error message was displayed by R_R.

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Mon 24 Aug 2020, 4:55 pm

I had started to look for errors like these but you beat me to it. The only manual editing I have done to either file is to replace an item of commercial stock with a freeware one in the ATSF activity. I am about to do the same for the other file, as there are five items of rolling stock I don't have.
I'll make those changes, correct the errors you found and report back.
BTW Route Riter didn't like the Blue Comet route at all and threw up a number of error messages before freezing.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Mon 24 Aug 2020, 6:21 pm

Hi Jonathan,
With respect, I think you've done quite a lot of editing to the Troop Train activity! I compared the original .act file with the one you sent me.
The Race Train activity file you sent me is different to the one in the pack I downloaded yesterday; and the date of yours is 27 Nov 2018 but the one from the pack is 13 Oct 2018!

There's very little wrong with the Blue Comet route - Route_Riter only gave a couple of missing .ace file messages, which it copied from another route and a hazard file (crowhaz1). I can't tell you why yours failed in such a way because I don't know exactly what you did! I assume you unpacked and copied all 8 files into your installation. If so, I can only suggest that you re-read the excellent Blue Comet Line installation.txt to find out if you did go wrong somewhere.

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty -

Post  Jonathan David Mon 24 Aug 2020, 6:36 pm

I also discovered another error in one of the activities _ an underscore instead of a space between the file name and the folder name), but with those fixed and the missing stock replaced everything now seems to work fine in both Activity Manager and Route Riter.
I still have to replace some stock I don't have in a few consists but those consists are not used by any of the activities. They are usually commercial stock items.
Many thanks for your help and for the brilliant Activity Manager program.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Mon 24 Aug 2020, 6:43 pm

I posted the above before I read your last post. Very strange as although I had possibly made some changes to the Activity files they were definitely not in the sections where there were errors.
I have had the Blue Comet route for some time and have run many of the activities successfully in the past when I was still using MSTS. It is a lot more interesting than the desert in the Seligman sub.
Many of the changes to American activities are caused by the extensive use of shape files from the commercial SLI offerings. There is now a free download with many of the shape files for locomotives but none for rolling stock. Hence the need for so many stock changes.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Mon 24 Aug 2020, 9:26 pm

Hi Jonathan,
Troop Train Activity
Line 918 from the file downloaded : WagonData ( up508343 UP_FreightPak )
Line 918 from the file you sent : WagonData ( UP_Box_492257 "UP_Box_Pack )

These are in Loose Consist 32783, which also has 9 other stock changes.

The date of the original file is 16 Dec 2015 and that of yours is 16 May 2020 so it seems to have been edited quite recently.

Maybe you're using a later version of the activity?

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty MSTS_ActMan

Post  slipperman12 Wed 09 Sep 2020, 7:46 pm

Hi Jonathan,
I have now fixed the last two bugs you reported.

If you have the time and would be kind enough to check it out. it's available here : https://drive.google.com/file/d/1DkJd9Cl2GXXvmgwUmJW_McjVCdfRwkqT/view?usp=sharing

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Thu 10 Sep 2020, 2:25 pm

I found the errors in the two activities we had discussed and corrected them. The activity on the Seligman Sub route then ran fine except that with the locos I had used to substitute for commercial items the train was very slow up hill., the activity taking nine hours 30 minutes hours against the suggested 4 hours 45 minutes. I shall try the Blue Comet route activity shortly.
And I have to admit that although I have no memory of doing so I must have done quite a bit of editing of the two Consists. My apologies for causing you grief.
I have downloaded your latest version and will give it a play. I have now dismantled the temporary "giant" installation I faked but I am sure I can give it a good workout.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Thu 10 Sep 2020, 6:03 pm

Hi Jonathan,
You don't really cause me grief, mate Smile After all, if one of my programs fails in any way, there's only one person to blame!!

9 hours 30 mins??? Even at 4 hours 45 mins I'm afraid I'd have been bored stiff! Anything over 1 hour 30 mins is getting too much for me. Although I've got several North American activities, I don't think I'll be running many of them - trundling along at a low speed for hours on end through boring scenery doesn't hold any attraction for me!!

Looking forward to receiving your feedback, whatever it turns out to be!!

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Thu 10 Sep 2020, 9:44 pm

Not in one go! Half an hour of it a day for two weeks. I can stay awake that long. Actually it is an interesting route as American ones go, as the scenery is very varied and it has to be driven, not just watched, because of the varied gradients.
But that is a problem with the long American routes where sometimes the speed limit is 35mph for miles on end. On the whole I prefer the short lines with lots of industry.
I think I know now why that consist was changed. It is also used for an activity in another American route which I downloaded some time ago, though I don't think I even ran the activity so I didn't realise I hadn't finished it or checked it.
In passing, it is interesting how different practice in activity writing is in the UK and the USA. In the UK activities very rarely use commercial stock, whereas a large proportion of American activities do, and a lot of American stock relies on files from commercial stock.
I'll report back in due course.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Sat 12 Sep 2020, 4:10 pm

I have given the new version of ActMan a good workout and have not managed to break it. It worked fine every time.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Sat 12 Sep 2020, 6:06 pm

Hi Jonathan,
Many thanks. mate Smile

Whenever I see I have a message from you, I get a feeling of foreboding!!

I've had another member looking at it and he, too, has reported no problems.  That's not to say that someone, sometime won't find something, but I'll get this version uploaded this coming week!

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Thu 17 Sep 2020, 8:32 pm

It is working fine for me. Dozens of checks with no issues.
But I am getting something a bit odd, which is probably nothing to do with Activity Manager. When I run it to check Consists. I get the following error messages. I have copied the file name and Pasted it into the TrainCfg line, so they should be identical, but it makes no difference.

TrainCfg entry doesn't match file name.
Consist File : RMD1_Act4_SilkTrain (2).con
Line Number : TrainCfg ( RMD1_Act4_SilkTrain (2)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
TrainCfg entry doesn't match file name.
Consist File : VIA NightTrain.con
Line Number : TrainCfg ( VIA NightTrain
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
I am attaching a Zip file with the two Consists.
Any thoughts?
Jonathan
Attachments
Route-Riter issues - Page 2 Attachment
VIA NightTrain.zip You don't have permission to download attachments.(2 Kb) Downloaded 1 times

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Thu 17 Sep 2020, 8:58 pm

Hi Jonathan,
Yes, mate!

Have you created these consists?
Both TrainCfg names contain spaces so, as far as I am aware, they must be within quotes - this also applies when brackets are included in a name. :

TrainCfg ( "RMD1_Act4_SilkTrain (2)"
TrainCfg ( "VIA NightTrain"

Also, if the Line Number wasn't shown, I apologise - I'll put on the ToDo List!

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Thu 17 Sep 2020, 10:29 pm

Thanks. That works.
No, in this case I hadn't changed them other than to replace the existing TrainCfg line with the file name, which in each case looked identical. There were certainly no quote marks to start with.
They came with a route, but I don't think they are used in any of the activities which came with the route. I was looking at Consists which had commercial stock at the time.
The line number doesn't matter in this case as it is always in the same position near the head of the file. Line numbers come up for missing stock.
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  slipperman12 Fri 18 Sep 2020, 2:24 pm

Hi Jonathan,
There were certainly no quote marks to start with.
After you posted the above, I got to wondering if I'd been wrong all along!  Therefore, I did a simple test with one of the default S&C activities.  I can now categorically say that if there are spaces in the TrainCfg entry, the whole value must be enclosed in double-quotes (as applies to all other MSTS parameter values).  If what you posted is true, MSTS would never have started without reporting an error.

The same would happen with the consist name which includes brackets, as these are used by MSTS to delineate parameter values and sections within all of its files.

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Jonathan David Fri 18 Sep 2020, 5:48 pm

In am afraid that there are quite a few minor errors in the Consists which come with either stock or routes, especially American ones. But if they are not used in Activities they may well never be checked.
A classic case recently. A Consist had three locomotives of the same class at its head. The middle one flagged up as missing so I looked at the Trainset files for the three locos. Although created by the same person at the same time the middle one had a slightly different format to the name, a hyphen where the others didn't. But whoever wrote the Consist hadn't noticed.
But I am not complaining. There is so much great free stuff for MSTS and OpenRails which I could never start writing. All I have ever managed is reskins of British private owner coal wagons. I would love to create a route based on the Pontypool Road to Neath line in South Wales, but that would be a real challenge - more than one junction per mile.
Should we perhaps get this thread renamed as it has had no connection with its title for ages?
Jonathan

Jonathan David

Posts : 186
Join date : 2016-08-10
Age : 74
Location : Newtown, Powys

Back to top Go down

Route-Riter issues - Page 2 Empty Re: Route-Riter issues

Post  Sponsored content


Sponsored content


Back to top Go down

Page 2 of 2 Previous  1, 2

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum