Train Sim Safe House
Would you like to react to this message? Create an account in a few clicks or log in to continue.

UK FineScale installer issues

Go down

UK FineScale installer issues Empty UK FineScale installer issues

Post  stlsf4003 Fri 15 Feb 2019, 8:13 pm

(Sorry if i'm posting this in the wrong place.)

Howdy y'all!

I'm kind of new here so i'll keep this brief.

I've been trying to install the UK FineScale track system for the last few days now and I've tried both the installer's from UKTrainsim and Stemea4me, yet none of them work.

So I thought I'ed try the installer for y'all's download library.

I downloaded it and after installing the installer, I tried once more to install UK finescale and it seemed to work well up until after selecting my destination folder.

I hit the OK button and then it throws up this error message.
(Object reference not set to an instance of an object)
There's also a details log if you need more information.

So this just begs the question.
What am i doing wrong?

stlsf4003

Posts : 11
Join date : 2019-02-15
Age : 25

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  slipperman12 Fri 15 Feb 2019, 9:29 pm

Hi st1sf4003,
I don't know where you got the error message or log from, but the versions of UKFS obtainable from UKTS and Steam4Me only allow installing into the default MSTS installation, as defined by its Registry entries.  

Have you tried my utility, UKFS_Install (ukfs_install_v1_0.zip from trainsim.com or UKTS_36731)?  It will allow you to install UKFS wherever you wish, even if you don't have MSTS installed.

Just in case you are referring to my utility, I've just successfully tested it in up-to-date Win 7 and Win 10 installations.

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  stlsf4003 Sat 16 Feb 2019, 12:19 am

slipperman12 wrote:Hi st1sf4003,
I don't know where you got the error message or log from, but the versions of UKFS obtainable from UKTS and Steam4Me only allow installing into the default MSTS installation, as defined by its Registry entries.  

Have you tried my utility, UKFS_Install (ukfs_install_v1_0.zip from trainsim.com or UKTS_36731)?  It will allow you to install UKFS wherever you wish, even if you don't have MSTS installed.

Just in case you are referring to my utility, I've just successfully tested it in up-to-date Win 7 and Win 10 installations.

Cheers,
Ged

I've been using your utility from the safe houses's file library.
Is there a difference between that version and the one's on UK or Trainsim?

stlsf4003

Posts : 11
Join date : 2019-02-15
Age : 25

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  slipperman12 Sat 16 Feb 2019, 9:29 am

Hi st1sf4003,
No mate, they should be the same version Smile

You haven't clarified your problem - is it with the UKFS installer or my utility? I doubt if it's the latter because there's no OK button or log!  However, if it is, please detail exactly your actions before the error occurred.

Thanks

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  stlsf4003 Sat 16 Feb 2019, 9:55 pm

slipperman12 wrote:Hi st1sf4003,
No mate, they should be the same version Smile

You haven't clarified your problem - is it with the UKFS installer or my utility? I doubt if it's the latter because there's no OK button or log!  However, if it is, please detail exactly your actions before the error occurred.

Thanks

Cheers,
Ged

I'ed show you what I've been doing but i can't seem to figure out how to post picture's on here, so i'll try and describe it the best i can.

First i opened the installer then clicked on the start button.

After doing that, it takes me to a folder browser that ask's me to select a folder to install FineScale to.
My install being: C:\Microsoft Games\Train Simulator.

Once that's done. I hit the OK button in the folder browser to close that out.

Now i'm back on the installer and in the space below where it says "Selected destination folder." It has the install path i just talked about.

It then goes on to say. "To confirm UKFS is to be installed into this folder, please click or to re-select ."

So i hit the yes button and it throws up the error I've already talked about. But for the sake of completeness, here's the error message word for word along with a details report.

Error message: "Unhandled exception has occurred in a component in your application. If you click Continue, the application will ignore this error and attempt to continue. Object reference not set to an instance of an object."

Details log:
************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at UKFS_Install.Form1.updateRegistry()
at UKFS_Install.Form1.btnYes_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
UKFS_Install
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/UKFS_Install/UKFS_Install.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3353.0 built by: NET472REL1LAST_B
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3221.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3221.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

That's all I've got.



stlsf4003

Posts : 11
Join date : 2019-02-15
Age : 25

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  slipperman12 Sat 16 Feb 2019, 11:36 pm

Hi st1sf4003,
Many thanks for your report.
The reason for the error appears to be because you don't have a Registry entry for MSTS.  This shouldn't have been a problem as UKFS_Install creates its own 'dummy' entry. I'm sure this worked correctly when the utility was originally released; I can only put it down to some Windows update.  It will take a while to sort out, but in the meantine, may I direct you to this page of a French site, https://www.activitysimulatorworld.net/Les_utilitaires/UK_FineScale.htm where you can download the same version of UKFS which will allow you to select your installation folder.  You don't need to be a member to get it Smile

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  stlsf4003 Sun 17 Feb 2019, 5:38 am

Slipp, I can't thank you enough for the help! Very Happy

The only issue you i'm having now is that the cross-ties keep flickering in and out whenever i move the camera or a locomotive.

stlsf4003

Posts : 11
Join date : 2019-02-15
Age : 25

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  slipperman12 Sun 17 Feb 2019, 9:56 am

Hi st1sf4003,
To cure the 'shimmering', please use my UKFS_Fix utility (from this site's library, UKTS 36632 or ukfs-fix2.zip from trainsim)

I REALLY hope you have no trouble with that one !!

I've found the problem with UKFS_Install, but, for the life of me, don't understand why it didn't come up during testing!  It was two years ago, so there could have been some subtle changes within Windows.

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  stlsf4003 Thu 21 Feb 2019, 7:47 am

sorry for the late reply ^^;

For one reason or another. when i select the folder i have UKFS installed in, It keeps saying that "There are no UKFS files in this folder."

stlsf4003

Posts : 11
Join date : 2019-02-15
Age : 25

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  slipperman12 Thu 21 Feb 2019, 1:54 pm

Hi st1sf4003,
Sorry, mate, but there can only be one reason for that error message, i.e the folder you've selected doesn't contain any files with 'ukfs' in their name!! I suggest you have a closer look - if you're using a 'normal' MSTS/ORTS file/folder hierarchy, you must select the SHAPES folder within the GLOBAL folder.

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  stlsf4003 Fri 22 Feb 2019, 9:16 pm

Well i'm happy to report that the fix installed without issue and the tie shimmering has stopped! Smile

stlsf4003

Posts : 11
Join date : 2019-02-15
Age : 25

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  slipperman12 Fri 22 Feb 2019, 9:39 pm

That's good news, mate Smile

Thanks.

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  Markh5682 Fri 22 Feb 2019, 11:59 pm

HI Ged.

I have downloaded your ukfs-fix2 shimmer fix, and have downloaded and installed the comp and decomp files, but the shimmer fix throws up an error message saying that comp/decomp files are not installed.

I installed the two files on the second drive where MSTS is installed and that didn't work, then I reinstalled them to the default c: drive location, still no luck.

Any Ideas?
Thanks.


Mark
Markh5682
Markh5682

Posts : 2615
Join date : 2013-01-21
Age : 66
Location : Lancashire

https://www.youtube.com/user/markh5682

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  slipperman12 Sat 23 Feb 2019, 12:25 am

Hi Mark,
Have you followed the instructions to run comp.exe and decomp.exe once before running UKFS-Fix (in red in the readme)?
This is necessary for their Registry entries to be created - I couldn't do it automatically because I've no control over where users install any programs!!

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 12GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 10 Pro 64 bit.

slipperman12

Posts : 1699
Join date : 2013-01-29
Age : 78
Location : North Nottinghamshire

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  Markh5682 Sat 23 Feb 2019, 10:54 am

Hi Ged.

I thought I had followed them but must have done something wrong, tried it again and all is up and running now, looks much better now without the shimmering. OK

Thanks.


Mark
Markh5682
Markh5682

Posts : 2615
Join date : 2013-01-21
Age : 66
Location : Lancashire

https://www.youtube.com/user/markh5682

Back to top Go down

UK FineScale installer issues Empty Re: UK FineScale installer issues

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum