Huddersfield & Environs LMS

Go down

Huddersfield & Environs LMS

Post  Jonathan David on Thu 16 Aug 2018, 9:06 am

Many thanks for the new route. It looks great - and I have already spotted the extension to Penistone, for which even more thanks.
In installing it I have followed my usual practice. First I made a copy of my "LMS and BR LMR routes" MSTS installation. Then I copied the new route into this.
But when I then try to select the route the screen freezes and MSTS crashes.
So I removed all the other routes. Huddersfield & Environs LMS now works fine once I had sorted out a suitable Consist - to be honest i just used Activity Editor to select a different loco.
The route runs smoothly and looks good.
Next I put back one of the routes which was originally in the folder - Burton-Derby.
The same problem. If I try to select Huddersfield & Environs MSTS crashes though if I select an activity in Burton-Derby there is no problem.
So I deleted Burton-Derby and replaced it by Thames-Mersey semaphore period
Now I can select the activity in Huddersfield & Environs but if I try to select the Thames-Mersey route MSTS crashes. Note that the difference now is that Huddersfield is first in the list of routes rather than second and therefore does not need to be selected.
So basically, the Huddersfield route is freezing the route selection window.
Now one solution is to run the route as a stand-alone but that will mean even more of my hard disk occupied by duplicate MSTS files and even more maintenance when I get a new piece of stock which will be needed for Huddersfield and other LMS routes, which I would prefer to avoid.
Any thoughts?
Jonathan
PS I have not investigated the route in Open Rails, though I know that one day soon I shall have to make the switch.

Jonathan David

Posts : 67
Join date : 2016-08-10
Age : 71
Location : Newtown, Powys

Back to top Go down

Re: Huddersfield & Environs LMS

Post  ShortNorth on Fri 17 Aug 2018, 1:10 am

G'day Johnathan,

Basically, I have TWO separate train simulator installations on my PC - one is for MSTS and one for ORTS.

The MSTS version has ALL the LMS area routes, Huddersfield, Black Country, Burton-Derby, Thames-Mersey and Thames-Trent all installed using a 'common' LMS Trainset, and then a similar installation for the ORTS setup. All works perfectly with no lock-ups.

The only time I have had MSTS lockup when selecting routes is when I have 'fiddled' with the stock or consist for the 'default' activity in that route. For the route released this week, the 'default' activity is a simple light engine movement from Mirfield shed to Hillhouse shed - this activity uses a exLYR 2-4-2T from the LMS CD / LMS Stock pack downloads. In the route info folders I stated that the LMS CD / LMS stock pack downloads should be installed before installing any other stock. As most, if not all, LMS enthusiasts would have the LMS CD / LMS stock pack downloads already installed, the default activity should run without problem.

Maybe the problem is that you have changed the stock for the 'default' activity and that is causing the problem - that is the only thing I can see that might cause it to lockup. Make sure you have the 'correct' loco and consist and try running it again.  I do extensive testing (as well as a few friends doing casual testing - not officially Beta testers, but have had no complaints from them) and check to make sure no problems arise before I release the route.

I've been building and releasing routes for well over 12 years now, mostly NSWGR, before I started on my LMS / LMS pre-grouping stuff, and have never had any route lockup or reported as lockup before.

I have NOT been able to replicate your problem - other than that, I have no other answers - everything works perfectly OK in either installation for me.

Regards, Brian


"Any railway that paints their locomotives such a magnificent shade of red, must be the most superior in the land" (apologies to the late David Jenkinson).
avatar
ShortNorth

Posts : 170
Join date : 2013-01-22
Age : 72
Location : Brisbane, Queensland

http://shortnorth.steam4me.net/

Back to top Go down

Re: Huddersfield & Environs LMS

Post  Bob Latimer on Fri 17 Aug 2018, 9:56 pm

Is the problem caused by the fact that the consist for the default activity is not actually included? (At least I couldn't find it anywhere and had to create it myself.)

Bob.

Forget that. I see you created a consist.

Bob Latimer

Posts : 156
Join date : 2013-01-18
Age : 69
Location : Auckland, New Zealand

Back to top Go down

Re: Huddersfield & Environs LMS

Post  ShortNorth on Sat 18 Aug 2018, 1:32 am

Bob Latimer wrote:.......... the consist for the default activity is not actually included? ....................

The Consist in question is automatically installed with the LMS CD / LMS Stock Pack downloads, and is NOT included with the route.

Brian


"Any railway that paints their locomotives such a magnificent shade of red, must be the most superior in the land" (apologies to the late David Jenkinson).
avatar
ShortNorth

Posts : 170
Join date : 2013-01-22
Age : 72
Location : Brisbane, Queensland

http://shortnorth.steam4me.net/

Back to top Go down

Re: Huddersfield & Environs LMS

Post  Jonathan David on Sat 18 Aug 2018, 7:52 am

I have the set of files for the LMS stock pack downloaded but had never installed them (I seem to have plenty of LMS stock without!). I shall now do so, go back to the original consist and try again. I'll report back either way.
Jonathan

Jonathan David

Posts : 67
Join date : 2016-08-10
Age : 71
Location : Newtown, Powys

Back to top Go down

Re: Huddersfield & Environs LMS

Post  dforrest on Sat 18 Aug 2018, 1:02 pm

There was unfortunately an error in the .trk file in the turntable patch I have uploaded. I do not know whether this is what caused the problem. I have uploaded a corrected version.


David
avatar
dforrest

Posts : 432
Join date : 2013-01-21
Age : 73
Location : St. Vincent and the Grenadines (and in an earlier life, Hull)

Back to top Go down

Re: Huddersfield & Environs LMS

Post  Jonathan David on Sat 18 Aug 2018, 6:32 pm

I hadn't installed the turntable patch as I have not yet switched to Open Rails.
But I have now installed the relevant files from the LMS stock pack and re-instated the original version of the activity The activity runs fine.
But when i try to have more than one route in the routes list the program still freezes up and crashes when I click on one of the routes in the list.
So I will run this as a free-standing route until a solution is found.
By the way I am running MSTS under Windows 10.
Jonathan

Jonathan David

Posts : 67
Join date : 2016-08-10
Age : 71
Location : Newtown, Powys

Back to top Go down

Re: Huddersfield & Environs LMS

Post  slipperman12 on Sat 18 Aug 2018, 8:06 pm

Hi Jonathan,
What is this "other" route?
Have you installed all its required add-ons? (UKFS, New Roads, etc.).

Cheers,
Ged


Intel i5 4690K (3.5GHz), Gigabyte GA-Z97P-D3 m/b, 8GB RAM, NVIDIA GTX 750ti (2GB), ASUS Xonar DS Sound Card, Win 7 Pro 64 bit.

slipperman12

Posts : 1370
Join date : 2013-01-29
Age : 76
Location : North Nottinghamshire

Back to top Go down

Re: Huddersfield & Environs LMS

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum